Klausimai pažymėti 'pg'

„pg“ yra „Ruby“ plėtinio pavadinimas, kuris suteikia prieigą prie „libpq“, „C“ programuotojų sąsajos su „PostgreSQL RDBMS“.
38
atsakymai

Nepavyko rasti libpq-fe.h antraštės, kai bandote įdiegti „pg gem“

Naudoju Ruby on Rails 3.1 versijos išleidimo versiją. Man patinka naudoti „PostgreSQL“, tačiau problema yra įdiegti „pg gem“. Tai suteikia man šią klaidą: $ gem install pg Statybinių vietinių plėtinių kūrimas. Tai gali užtrukti ... ERROR: E ...
gegužės 18 d. 11 val
17
atsakymai

Kaip įdiegti PostgreSQL pg gem Ubuntu?

Bandau įdiegti PostgreSQL pg gem Ruby. Aš išleidau šią komandą: gem install pg Aš įdiegiau Ruby 1.9.2 naudojant RVM. Pirmiau pateikta komanda man parodo šią klaidą. Klaida: kuriant vietinius plėtinius. Tai gali užtrukti ...
birželio 25 d. 10 val
23
atsakymai

PG :: ConnectionBad - nepavyko prisijungti prie serverio: ryšys atmestas

Kiekvieną kartą, kai paleidžiu bėgių 4.0 serverį, gaunu šią išvestį. Pradėjo GET "/" už 127.0.0.1, 2013-11-06 23:56:36 -0500 PG :: ConnectionBad ...
lapkričio 7 d. '13, 8:06
16
atsakymai

Bėgiai 3 - negali įdiegti pg gem

Kai bandau paleisti paketą (paketų įdiegimą), visada gausiu diegimą pg (0.13.2) su vietiniais plėtiniais Gem :: Installer :: ExtensionBuildError: KLAIDA: nepavyko sukurti „gem native“ plėtinio. /Users/ryan/.rvm/rubies/ruby-1.9.2-p290 / ...
kovo 12 d. 12 val. 17:17
16
atsakymai

gem install pg --with-pg-config veikia, paketas neveikia

Kai paleisiu (kaip root) gem install pg -v '0.12.0' - --with-pg-config = / usr / pgsql-9.1 / bin / pg_config Gavau tokią produkciją: # -> gem install pg -v '0.12.0' - --with-pg-config = / usr / pgsql-9.1 / bin / pg_config Vietinių plėtinių kūrimas. Tai ...
nustatytas vasario 11 d '12 0:20
8
atsakymai

Nepavyko įdiegti „pg gem“ „Mavericks“ naudojant „Postgres.app“

Bandau įdiegti „pg gem“, skirtą naudoti su „Postgres.app“ savo vietiniame kompiuteryje. Aš paleisiu „Mavericks“. Postgres.app yra įdiegtas ir veikia gerai, bet aš negaliu gauti akmens. Aš padariau šiuos veiksmus: Naudojama komanda yra env ARCHFLAGS = ...
lapkričio 26 d. '13, 20:55
12
atsakymai

rails install pg - Nerandate libpq-fe.h antraštės

$ sudo paketo įdiegimas Rezultatų gavimo metaduomenys iš https: //rubygems.org / ........... Gem metaduomenų rinkimas iš https://rubygems.org/ .. Naudojant „Rake“ (0.9.2.2) i18n (0.6.1) Naudojant multi_json (1.3.6) Aktyvaus palaikymo naudojimas (3.2.8) Naudojant b ...
nustatyti spalio 26 d '12, 14:27
10
atsakymai

„ActiveRecord“ :: StatementInvalid: PG InFailedSqlTransaction

Bandau sukurti „ActiveRecord“ objektą. Bet gaunu šią klaidą, kai ją sukuriu. (0.1ms) ROLLBACK ActiveRecord :: StatementInvalid: PG :: InFailedSqlTransaction: KLAIDA: dabartinė operacija nutraukiama, komandos ignoruojamos iki sandorio pabaigos ...
15 Jan '14, 16:05
11
atsakymai

KLAIDA: Nepavyko sukurti vietinio „gem“ plėtinio „Mavericks“

Bandau paleisti paketą „Rails“ projekte „OSX 10.9“. Tai nepavyksta, kai į šią klaidą įsijungia juvelyriniai dirbiniai į „pg“: Gem :: Installer :: ExtensionBuildError: ERROR: nepavyko sukurti „gem native“ plėtinio. /Users/kyledecot/.rvm/rubies/ruby-2.0.0-p ...
nustatyti 24 okt. '13, 17:40
10
atsakymai

„Postgresql“ adapteris (psl.): Negali prisijungti prie serverio

Šią klaidą gaunu kiekvieną kartą, kai paleidžiu „Rails“ programą (ji negali prisijungti prie mano vietinio „Postgresql“) /Users/leonardo/.rvm/gems/ruby-1.9.3-p362/gems/activerecord-3.2.11/lib/ active_record / connection_adapters / postgresql_adapter ....
nustatyti 09 sausis '13 - 1:20
3
atsakymai

„PostgreSQL“ vaizdo kameros įdiegimas su „gem pq“ nepavyksta: KLAIDA: Nepavyko sukurti savo brangakmenio plėtinio

Aš mokau Ruby on Rails ir bandau sukurti programą. Savo paraiškoje bandau naudoti standartinę SQLite duomenų bazę kūrimo režimu ir PostgreSQL gamybos režimu. Bet kai bandau įdiegti „pg gem“, gaunu šią klaidą: ...
rugsėjo 18 d '13, 7:52
13
atsakymai

gem install pg neveikia OSX Lion

Yra daug šio klausimo variantų, kurie grįžta aplink SO, bet nė vienas iš jų, atrodo, neturi atsakymo, kuris išspręstų mano problemą. Paleidžiu OSX Lion (10.7.3). Įdiegtas paskutinis Xcode. Įdiegiau „Postgres“ naudodamas „Postgres.app“ paketą iš pos ...
nustatytas balandžio 27 d '12, 7:42
4
atsakymai

Bandykite sukonfigūruoti „ror“ taikomąją programą, gauti klaidą - fe_sendauth: nenurodytas slaptažodis

Gauti: įvyko klaida: Klaida: nėra slaptažodžiu pateiktų nustatymų duomenų bazės .yml nustatymai sutampa su kitų įrenginių taikomųjų programų nustatymais. Kaip aš galiu pritaikyti dalykus, kad nereikėtų koduoti ...
nustatytas 17 sep. '12, 4:09
3
atsakymai

gem install pg negali bendrauti su libpq

Atnaujinus į Ruby 1.9.3 (nuo 1.9.2 versijos naudojant RVM sistemą) Ubuntu 10.04.3, ištrinau visus mano brangakmenius ir bandžiau iš naujo įdiegti pg (ala bundle install pg). Tada jis padarė klaidą ir informavo mane, kad turėčiau ...
nustatytas sausio 11 d '12, 9:10
2
atsakymai

PG :: Klaida: KLAIDA: santykių „naudotojai“ neegzistuoja

Apgailestaujame, kad jums rūpi, bet turiu daug klausimų apie šią klaidą. pirmiausia tai mano user_controller rspec failas, reikalingas „spec / spec_helper“, kuris apibūdina „UserController“ tai „sukurkite naują vartotoją“, rašykite „kurti“ priskiria [: naudotojams] .should_not be_new _...
Nustatyta liepos 17 d. 12 val. 22:42
"192.102.6.96 - 192.102.6.96"