Klausimai pažymėti „pip“

Naudokite „Python Package Installer“ klausimus
35
atsakymai

Kaip įdiegti „pip“ sistemoje „Windows“?

pip yra easy_install pakaitalas. Bet ar turėčiau įdiegti „pip“ naudojant „easy_install“ sistemoje „Windows“? Ar yra geresnis būdas?
nustatė sausio 20 d '11 21:08
21
atsakymas

Kaip įdiegti „pip“ į „MacOS“ arba „OS X“?

Vakar aš didžiąją laiko dalį praleidžiau ieškant aiškaus atsakymo į „pip“ („Python“ paketo tvarkyklės) diegimą. Aš negaliu rasti gero sprendimo. Kaip jį įdiegti?
yra nustatyta birželio 24 d. 13 val
51
atsakymas

Atnaujinami visi paketai su pip

Ar galima vienu metu atnaujinti visus „Python“ paketus su „pip“? Atkreipkite dėmesį, kad oficialioje sekimo problemoje yra užklausa dėl funkcijos.
nustatytas balandžio 27 d '10, 12:23
7
atsakymai

Įdiegus tam tikras paketo versijas naudojant pip

Bandau įdiegti „MySQL_python“ adapterio 1.2.2 versiją naudojant naują virtualenv, sukurtą parinktimi -no-site-package. Dabartinė „PyPi“ versija yra 1.2.3. Ar galima įdiegti senesnę versiją? Radau straipsnį, kuriame ...
nustatė kovo 8 d. 11 val
9
atsakymai

Kodėl naudoti „pip“ „easy_install“?

„Tweet“ teigia: „Easy_install“ nenaudokite, jei nenaudojate kaip dūrio. Naudokite pip. Kodėl naudoti „pip“ „easy_install“? Ar problema daugiausia susijusi su „PyPI“ ir paketų autoriais? Jei autorius atsisiunčia archyvą ...
liepos 10 d. 10 val
41
atsakymas

Klaida: nepavyko rasti vcvarsall.bat

Bandžiau įdiegti Python dulwich paketą: pip install dulwich Bet aš gavau slaptą klaidos pranešimą: klaida: nepavyko rasti vcvarsall.bat Tas pats nutinka, jei bandau įdiegti paketą rankiniu būdu:> python setup.py install ...
gegužės 12 d. 13 val
23
atsakymai

Kaip gauti vietinių įdiegtų „Python“ modulių sąrašą?

Norėčiau gauti Python modulių, esančių „Python“ diegimo programoje (UNIX serveryje), sąrašą. Kaip galite gauti kompiuteryje įdiegtų „Python“ modulių sąrašą?
nustatytas balandžio 11 d '09 15:34
10
atsakymai

Kaip įdiegti paketus su „pip“ pagal „local.txt“ failą iš vietinio katalogo?

Čia yra problema, turiu reikalavimų failą. atrodo taip: BeautifulSoup == 3.2.0 Django == 1.3 Audinys == 1.2.0 Jinja2 == 2.5.5 PyYAML == 3,09 Pygments == 1,4 SQLAlchemy == 0.7.1 Pietų == 0.7.3 amqplib == 0.6. 1 anyjson == 0.3 ... turiu vietinį archyvų katalogą, ...
paklausė 29 rug. '11, 6:53
19
atsakymai

pip install mysql-python neveikia su EnvironmentError: mysql_config nerastas

Tai yra klaida, kurią gaunu (mysite) zjm1126 @ zjm1126-G41MT-S2: ~ / zjm_test / mysite $ pip įdiegti mysql-python „mysql-python“ atsisiuntimas / išpakavimas „MySQL-python-1.2.3.tar.gz“ atsisiuntimas: Atsisiųsti 70Kb Running setup.py egg_info paketui m ...
nustatyti kovo 03 '11 11:32
11
atsakymai

Kaip įdiegti Python paketą su .whl failu?

Turiu problemų diegiant „Python“ paketą (ypač „JPype1 0.5.7“) savo „Windows“ įrenginyje ir norite jį įdiegti naudojant „Crystaloph“ dvejetainius „Gohlke“ >
nustatytas sausio 11 d '15, 11:48
10
atsakymai

Sužinokite, kuri paketo versija įdiegta naudojant „pip“

Naudojant pip, galima nustatyti, kuri paketo versija šiuo metu įdiegta? Aš žinau apie „pip install XYZ -upgrade“, bet man įdomu, ar yra kažkas panašaus į „pip info XYZ“. Jei ne, koks būtų geriausias būdas pasakyti, kurią versiją aš naudoju ...
balandžio 18 d '12 20:37
4
atsakymai

„pip“ įdiegti iš „git repo“ filialo

Bandymas grąžinti atpirkimą konkrečiai pramonei. „Google“ man sako „pip install git“ + https://github.com/user/repo.git@branch Filialo pavadinimas išduodamas / 34 / oscar-0.6, todėl aš įdiegiu https://github.com/tangentlabs/django-oscar-paypal .git @ / numeris / 34 ...
nustatyti lapkričio 20 d '13, 19:46
10
atsakymai

Koks skirtumas tarp „pip“ ir „conda“?

Žinau, kad „pip“ yra paketų tvarkyklė „python“ paketams. Tačiau pamačiau, kad diegimas IPython svetainėje naudoja conda, kad įdiegtų IPython. Ar galiu naudoti „pip“ įdiegti „IPython“? Kodėl turėčiau naudoti Conda kaip a.
nustatyti 08 sausis '14, 14:44
25
atsakymai

Kaip įdiegti psycopg2 naudojant „pip“ Python?

Aš naudoju virtualenv, ir turiu įdiegti „psycopg2“. Aš atlikiau šiuos veiksmus: pip install http://pypi.python.org/packages/source/p/psycopg2/psycopg2-2.4.tar.gz#md5=24f4368e2cfdc1a2b03282ddda814160 Ir turiu šiuos pranešimus: Atsisiunčiama ...
Nustatykite kovo 24 d
26
atsakymai

pg_config vykdomas failas nerastas

Turiu problemų diegiant psycopg2. Bandydamas įdiegti psycopg2, gaunu šią klaidą: Klaida: nepavyko rasti failo pg_config. Pridėkite katalogą, kuriame yra pg_config, į PATH arba nurodykite vykdomąjį kelią su ...
liepos 23 d. 12 val. 22:09