Klausimai pažymėti „bundler“

„Bundler“ yra įrankis, kuris leidžia lengvai stebėti, kas priklauso nuo „Ruby Rubies“ (ir kokių šių brangakmenių versijų). Tai daroma įdiegiant visus „Gemfile“ programų brangakmenius. Pati „Bundler“ yra perlas ir gali būti įdiegta taip: $ gem install bundler
7
atsakymai

Ar Gemfile.lock turėtų būti įtrauktas į .gitignore?

Aš esu kažkas naujo paketui ir failams, kuriuos jis sukuria. Turiu GitHub git saugyklos kopiją, į kurią daugelis prisideda, todėl nustebau, kad paketas sukūrė failą, kuris neegzistavo repo ir nebuvo .giti sąraše ...
lapkričio 11 d. '10, 8:03
4
atsakymai

„Bundler“: ką reiškia: reikalauti => klaidinga gemfile?

Linija yra tokia: perlas „kada“,: reikalauja => false Ar tai reiškia, kad akmuo turi būti įrengtas ar nereikalingas?
nustatytas 26 sausis '11, 4:46
6
atsakymai

Ką reiškia exec exec?

Ką reiškia paketas exec rake db: migruoti? Arba tiesiog paketą exec rake <command> apskritai? Suprantu, kad paketas rūpinasi daiktų taupymu gemfile. Žinau, ką reiškia žodis „exec“. Suprantu, kad rake palaiko visus skirtingus scenarijus ...
liepos 5 d. 11 d. 23:46
5
atsakymai

Kaip galiu nurodyti gemfile vietinį perlas?

Norėčiau, kad Bundleris atsisiųstų vietinį perlas. Ar tai yra galimybė? Arba turiu perkelti brangakmenių aplanką į .bundle katalogą?
gruodžio 20 d '10, 11:24
28
atsakymai

paketo diegimo klaida su SSL sertifikato patvirtinimo klaida

Kai paleidžiu paketą „Rails 3“ projektui „Centos 5.5“, tai nepavyksta su klaida: Gem :: RemoteFetcher :: FetchError: SSL_connect grįžta = 1 errno = 0 būsena = SSLv3 skaityti serverio sertifikatas B: sertifikato patikra nepavyko (https: / /bb-m.ru ...
nustatytas balandžio 20 d '12 15:13
7
atsakymai

Kaip galiu nurodyti gemfile vietinius .gem failus?

Turiu keletą brangakmenių failų, kuriuos įdiegiu per gem install xx.gem. Ar galiu pasakyti Bundleriui juos naudoti? Arba turiu nurodyti kelią į šaltinio failą?
nustatytas balandžio 12 d '11 13:41
12
atsakymai

paketas: komanda nerasta

Aš įdėjau į vps, ubuntu 10.04, bėgius 3, rubiną ir mysql tinkamai įdiegus keletą pamokų. Jei paleisiu paketų čekį arba paketą, gausiu klaidą '- bash: bundle: komanda nerasta'. Iš brangakmenių sąrašo - vietinis, matau „paketą (1.0 ...
nustatyti 12 okt. '10, 15:32
6
atsakymai

Nepavyko rasti gemfile

Žinoma, aš nesu Ruby kūrėjas, bet turiu programą savo serveryje, naudodamas Ruby, Gems ir Bundler. Bandau įdiegti kitą „Ruby“ į kitą vartotojo abonementą, bet tuo pačiu VPS. Kai einu paleisti paketą įdiegti ...
nustatytas liepos 25 d
3
atsakymai

Koks skirtumas tarp „Gemfile“ ir „Gemfile.lock“ Ruby on Rails?

Aš pradedu Ruby on Rails ir aš naudoju Rails 3.0.9. Koks skirtumas tarp Gemfile ir Gemfile.lock Rails?
nustatytas 03 rugpjūtis '11 4:45 val
13
atsakymai

Klaida „Nepavyko rasti paketo“

Kai bandau atlikti paketo atnaujinimą, gaunu šią klaidą: .rvm / rubinus / ruby-1.9.2-p180 / lib / ruby ​​/ site_ruby / 1.9.1 / rubygems / dependency.rb: 247: „to_specs“: nepavyko rasti paketą (> = 0) tarp [rake-0.8.7, rake-0.8.7, rubygems-update-1.8.4] (G ...
Nustatyta gegužės 29 d. 11 val
6
atsakymai

Koks yra geriausias būdas pašalinti brangakmenius iš bėgių3 projekto?

Aš įdiegiau visus savo brangakmenius naudodamas paketą per „gemfile“. Maniau (klaidingai), kad jei pašalinsiu brangakmenį iš mano „Gemfile“ ir bėgo „paketų įdiegimas“, kad ištrinti brangakmeniai būtų ištrinti. Peržiūrėjau failą cn ...
nustatė sausio 12 d '11 12:34
15
atsakymai

Neteisingas brangakmenis dėl datos formato specifikacijoje

Kai aš įjungsiu brangakmenį, kurį aš padariau, „Bundler“ (1.0.12 versija), „Gemfile“, tada bandau susieti ar sugadinti tai: $ rake Turiu šį klaidos pranešimą: Neteisingas brangakmenis [/ Vartotojai / zagzag /.rvm/gems/ruby-1.9 ....
nustatytas balandžio 24 d '11 19:31
3
atsakymai

Naudojant --no-rdoc ir -no-ri su pakuotoju

Naudojant perlas įdiegti „gem_name“, galiu perduoti „-no-rdoc“ ir „-no-ri“ jungiklius, kad praleistumėte „RDoc / RI“ dokumentacijos kūrimą, norint įdiegti perlas diegimo metu. Ar yra panašus būdas tai padaryti su paketo įdiegimu?
nustatytas 24 sep. '11, 2:09
6
atsakymai

Naudojant „npm“ įdiegti arba atnaujinti reikiamus paketus, pvz

Man patinka Bundler, tai puikiai tinka valdyti priklausomybes. Man patinka npm. Turiu „nodejs“ programą ir norėčiau nurodyti programų priklausomybes ir lengvai jas įdiegti / atnaujinti, ...
nustatyti 02 vas '11 10:49
5
atsakymai

Jau aktyvavote X, bet jūsų „Gemfile“ reikalauja „Y“

Kai paleisiu „Rake“, gaunu šią klaidą: jau aktyvavote „Rake 0.9.2“, tačiau jūsų „Gemfile“ reikia rake 0.8.7. Apsvarstykite galimybę naudoti paketą exec. Naudojant paketą exec rake, o ne tik rake, atrodo, veikia, bet ar geriau naudoti ...
yra nustatytas birželio 11 d. 11 val