Klausimai pažymėti „rubygems“

RubyGems yra Ruby programavimo kalbos paketo valdymo įrankis. Tai leidžia vartotojams atsisiųsti ir atnaujinti Ruby bibliotekas ir automatiškai išspręsti priklausomybes.
12
atsakymai

Kaip padaryti, kad --no-ri --no-rdoc būtų numatytasis „gem“ diegimo būdas?

Nenaudojau RI arba RDoc išvesties iš akmenų, kuriuos įdiegiu savo kompiuteryje arba serveriuose, kuriuos apdorojau (naudoju kitus dokumentacijos įrankius). Kiekvienas mano įdiegtas perlas, įdiegia RI ir RDoc dokumentus ...
nustatyti 05 Rgs '09 0:48
10
atsakymai

Kaip pašalinti RVM (Ruby Version Manager) iš mano sistemos?

Kaip pašalinti RVM (Ruby Version Manager) iš mano sistemos?
Nustatykite rugpjūčio 24 d '10 19:26
25
atsakymai

Įdiegus brangakmenį ar atnaujinant RubyGems nepavyksta su leidimo klaida

Bandymas įdiegti brangakmenį („gem install mygem“) arba atnaujinti „RubyGems“ („gem update“ - sistema) nepavyksta su klaida: KLAIDA: vykdydamas perlas ... („Gem :: FilePermissionError“) /Gems/2.0 ....
nustatytas sausio 30 d '13, 18:10
23
atsakymai

Klaida diegiant „mysql2“: Nepavyko sukurti priskirtų „gem“ plėtinių

Turiu problemų diegiant „mysql2“ perlas „Rails“. Kai bandau ją įdiegti paleisdamas paketų diegimą arba „gem“ įdiegti „mysql2“, tai sukelia šią klaidą: Klaida diegiant „mysql2“: ERROR: nepavyko sukurti savo išplėstinio ...
nustatyti 31 d. '10, 13:54
10
atsakymai

Kaip įdiegti perlas iš „GitHub“ šaltinio?

Norėčiau įdiegti perlas iš naujausio „GitHub“ šaltinio. Kaip tai padaryti?
nustatytas balandžio 05 d '10 10:26
7
atsakymai

homebrew neveikia OSX

Šios klaidos įjungimas, kai įjungiamas termostato komandas. Reikia pagalbos sprendžiant. /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb::in reikia:: negali įkelti tokių failų - utils / p. ..
yra nustatytas liepos 09 '14, 14:53
7
atsakymai

Kaip įdiegti vietinį perlą?

Jei atsisiųsiu .gem failą į aplanką kompiuteryje, ar galiu ją įdiegti vėliau naudojant „gem install“?
nustatyti spalio 21 d '08 1:32
15
atsakymai

gem install: Nepavyko sukurti pasirinktinio perlo plėtinio (nepavyko rasti antraštės failų)

Aš naudoju „Fedora 14“ ir turiu įdiegtą „MySQL“ ir „MySQL 5.1.42“ serverį. Dabar aš bandžiau tai padaryti kaip root: gem install mysql Bet aš gaunu šią klaidą: kuriant vietinius plėtinius. Tai gali užtrukti ... ERROR: Err ...
lapkričio 29 d. '10, 16:58
5
atsakymai

Kaip galiu nurodyti gemfile vietinį perlas?

Norėčiau, kad Bundleris atsisiųstų vietinį perlas. Ar tai yra galimybė? Arba turiu perkelti brangakmenių aplanką į .bundle katalogą?
gruodžio 20 d '10, 11:24
9
atsakymai

Įdiegiant „json gem“ įvyko klaida „mkmf.rb negali rasti rubino antraštės failų“

Kontekste, nuotoliniame serveryje su užkarda. Nustatau aplinką per įgaliotąjį serverį. Turiu rubiną 1.8.7. Kai bandau įdiegti gem .. sudo gem install --http-proxy <host address>: <port> json Aš gaunu šią klaidą: statyba ...
gruodžio 13 d. '13, 7:44
28
atsakymai

paketo diegimo klaida su SSL sertifikato patvirtinimo klaida

Kai paleidžiu paketą „Rails 3“ projektui „Centos 5.5“, tai nepavyksta su klaida: Gem :: RemoteFetcher :: FetchError: SSL_connect grįžta = 1 errno = 0 būsena = SSLv3 skaityti serverio sertifikatas B: sertifikato patikra nepavyko (https: / /bb-m.ru ...
nustatytas balandžio 20 d '12 15:13
11
atsakymai

Neapibrėžta konstanta „ActiveSupport“ :: Priklausomybės :: Mutex (NameError)

Kai noriu sukurti „Ruby on Rails“ projektą, gaunu žemiau esantį pranešimą. /usr/lib/ruby/gems/1.8/gems/activesupport-2.3.8/lib/active_support/dependencies.rb:55: neplanuotas nuolatinis ActiveSupport :: Dependencies :: Mutex (NameError) iš / usr / local / lib .. .
nustatykite kovo 03d
25
atsakymai

„rmagick gem install“ „Nepavyko rasti„ Magick-config “

Kai bandau įdiegti „rmagick“ perlas, gaunu žemiau pateiktą klaidą. Aš esu „Snowleopard 10.6“, naudodamas RVM, Ruby 1.9.2-head ir Rails 3.05. Atsakymus į šiuos klausimus rekomendavo „ImageMagick“, kurį sėkmingai padariau. Draugas ...
nustatytas kovo 05d
18
atsakymai

Kaip įdiegti „cocoapods“?

Aš paminėjo per daug nuorodų ir bandžiau, be sėkmės. Jei kas nors turi idėją, prašome pasidalinti su manimi. Aš perskaičiau dokumentus apie kakavos pupeles ir bandžiau įdiegti daug kartų, tačiau tai buvo neįmanoma dėl pradinių žingsnių. Radau vieną ...
nustatyti 24 dec. '13, 7:52
23
atsakymai

Biblioteka nėra įkeltas: klaida, kai bandoma paleisti bėgių serverį OS X 10.6 sistemoje naudojant „mysql2 gem“ libmysqlclient.16.dylib klaidą

Jau kurį laiką kovojau su tuo. Aš įdiegiau „Rails 3“, „gem“, „mysql“ ant mano „Snow Leopard“ mašinos. Viskas vyko tol, kol sukūriau savo pirmąjį projektą ir bandžiau paleisti bėgių serverį. Po to, kai pradėjau, gavau: jontybrook $ rails serv ...
gruodžio 28 d '11, 17:17