Klausimai pažymėti „lengva įdiegti“

„EasyInstall“ yra paketų tvarkyklė, teikianti standartinį Python programų ir bibliotekų platinimo formatą. „Setuptools“ modulio dalis.
35
atsakymai

Kaip įdiegti „pip“ sistemoje „Windows“?

pip yra easy_install pakaitalas. Bet ar turėčiau įdiegti „pip“ naudojant „easy_install“ sistemoje „Windows“? Ar yra geresnis būdas?
nustatė sausio 20 d '11 21:08
9
atsakymai

Kodėl naudoti „pip“ „easy_install“?

„Tweet“ teigia: „Easy_install“ nenaudokite, jei nenaudojate kaip dūrio. Naudokite pip. Kodėl naudoti „pip“ „easy_install“? Ar problema daugiausia susijusi su „PyPI“ ir paketų autoriais? Jei autorius atsisiunčia archyvą ...
liepos 10 d. 10 val
13
atsakymai

Kaip pašalinti paketus, įdiegtus naudojant easy_install Python?

„Python easy_install“ leidžia lengvai įdiegti naujus paketus. Tačiau, kiek aš galiu pasakyti, ji neįgyvendina kitų bendrų priklausomybės valdytojo funkcijų - įtrauktų paketų sąrašo ir ištrynimo. Koks yra geriausias būdas sužinoti, kas įdiegta ir kaip ...
nustatyti 05 rug '09 10:33
9
atsakymai

Kaip įdiegti lxml Ubuntu

Man sunku įdiegti „lxml“ su „easy_install“ į „Ubuntu 11“. Kai aš įvesiu $ easy_install lxml, gaunu: „lxml skaitymas“ http://pypi.python.org/simple/lxml/ Skaitymas http://codespeak.net/lxml Geriausias atitikimas : lxml 2.3 Atsisiuntimas http: //lxml.d ...
birželio 28 d. 11 val
15
atsakymai

Rasti visus paketus, įdiegtus naudojant easy_install / pip?

Ar galima rasti visus „PyPI Python“ paketus, kurie buvo įdiegti naudojant easy_install arba pip? Aš turiu galvoje, išskyrus viską, kas buvo / yra įdiegta su platinimo įrankiais (šiuo atveju apt-get Debian'e).
yra nustatytas liepos 06 d. 11 val
1
atsakymas

Koks skirtumas tarp dist-paketų ir svetainių paketų?

Aš šiek tiek erzina „python“ paketo įdiegimą. Konkrečiai, koks skirtumas tarp pakuočių, įdiegtų į dist-package katalogą ir svetainių paketų katalogą?
nustatytas vasario 22 d '12, 4:29
11
atsakymai

„SetupTools“ diegimas 64 bitų „Windows“ sistemoje

Python 2.7 paleidžiu 64 bitų „Windows 7“ versijoje, o kai paleidžiu diegimo programą, noriu pasakyti, kad „Python 2.7“ nėra įdiegta. Konkretus klaidos pranešimas: „Reikalinga„ Python 2.7 versija “
nustatyti 06 rugsėjis '10, 18:32
8
atsakymai

„Python“ paketas neprisijungęs

Koks yra geriausias būdas atsisiųsti „python“ paketą ir jo priklausomybes nuo „pypi“ neprisijungus kitam įrenginiui? Ar yra paprastas būdas tai padaryti naudojant „pip“ arba „easy_install“? Bandau įdiegti užklausų biblioteką FreeBSD lauke, kurio nėra ...
birželio 19 d. 12 val
3
atsakymai

Ar galiu naudoti „pip“, o ne „easy_install“, jei naudojate „python“ priklausomybę „setup.py install“?

„python setup.py“ įdiegimas automatiškai įdiegs paketus, nurodytus „Requ =“ [] naudojant easy_install. Kaip galiu gauti „pip“?
nustatytas sausio 18 d '10, 18:40
18
atsakymai

ImportError: nėra modulio, pavadinto „Crypto.Cipher“

Kai bandau paleisti „app.py“ („Python 3.3“, „PyCrypto 2.6“), mano virtualenv ir toliau grąžina pirmiau nurodytą klaidą. Importavimo operacija yra tiesiog iš „Crypto.Cipher import“ AES. Aš ieškojau dublikatų ir galėtumėte pasakyti, kad yra keletas, bet aš ...
nustatyti spalio 27 d '13, 23:39
16
atsakymai

Koks yra oficialus „pageidaujamas“ būdas įdiegti pip ir virtualenv sistemą?

Tai, ką žmonės dažniausiai rekomenduoja: $ sudo apt-get install python-setuptools $ sudo easy_install pip $ sudo pip install virtualenv Ar tai, ką aš gavau iš http://www.pip-installer.org/en/latest /installing.html: $ curl -O https: //github.c ...
07 Bal '11 21:36
24
atsakymai

problema diegiant beveik bet kokią biblioteką

Aš sunkiai naudojasi pip įdiegti beveik viską. Aš esu naujas kodavimas, todėl maniau, kad tai yra tai, ką aš darau neteisingai, ir atsisakiau easy_install gauti didžiausią tai, ko man reikia ...
gegužės 04 d. 13 val
12
atsakymai

ImportError: nėra modulio PIL

Šią komandą naudoju korpuse, kad įdiegtumėte PIL: easy_install PIL, tada aš pradėjau python ir įvedžiau: importuoti PIL. Bet gaunu šią klaidą: „Traceback“ (naujausias paskutinis skambutis): „<console>“, 1 eilutė, <module> ImportError ...
nustatytas sausio 14 d '12 20:24
3
atsakymai

Įdiekite konkrečią versiją naudodami easy_install

Bandau įdiegti „lxml“. Žiūrėjau į svetainę, o versija 2.2.8 man atrodė protinga, bet kai padariau „easy_install lxml“, ji įdiegė 2.3.beta1 versiją, kuri tikrai nėra taip, kaip manau. Koks yra geriausias būdas jį išspręsti ir kaip ...
nustatytas rugsėjo 30 d „10, 20:05
4
atsakymai

Problema diegiant PIL naudojant virtualenv arba buildout

Įdiegus PIL naudodamas „easy_install“ arba „buildout“, jis įdiegiamas taip, kad turiu „importuoti vaizdą“, o ne „iš vaizdo importavimo PIL“. Tačiau, jei paleidžiu apt-get install python vaizdą arba naudokite ...
Nustatykite kovo 21 d